Please provide your feedback in this short Flings' survey.
Nov 03, 2022

using an customized powershell script and a private registry don't seems to work. when i apply the edited function.yaml nothing change under the vmware-functions when i monitor witfh kubectl get pods -A i don't know where to look for some errors

Nov 03, 2022

Can you manually do a pull on VEBA appliance, ensure it has connectivity and can communicate with your private registry, especially on resolution and/or certificate trusts ...

Nov 03, 2022

Hello William,
if I do a of pull from private registry, it seem to be good : 'Status: Image is up to date'.
And image is working fine when i launch docker run from test directory.
About certificate : i added the certificate of the private registry to the certificate store of the veba appliance and a curl command of the private registry is working fine. I have no idea where to look to see why kubectl doesn't seem to ingest function.yaml file. I may probably have missed something when using a private registry. The only modification in function.yaml file is about the image location like indicated in the readme.

Nov 03, 2022

Can you do a describe on function and see if there's any hints on issue? You may also want to join our public slack for easier debugging

Nov 07, 2022

Thanks for the links, i think i will start over try with docker hub, it seem the issue come from the certificate and the private registry... The function was just a little different from the example about vm restarted by HA. Maybe i will join slack if i can't make any progress.