Please provide your feedback in this short Flings' survey.
Mar 27, 2019

Hello,

Is there any way to make this work by injecting the driver into the image? I injected the offline bundle, but it doesn't appear to recognize the USB network adapter on install, although it is the correct vendor/dev ids. The vmkusb driver appears to load and find the device, but I can't seem to get the network nic list to enumerate, and the esx.conf file doesn't make reference to a vusb0 during install. Here is a link to a picture of some commands I ran: https://photos.app.goo.gl/s7hZaTfaagSaQYUPA

Is there something I can do from shell that will allow the network adapter to be recognized?

Mar 27, 2019

Hi @Rennyfuchs,

I just checked the picture you shared on the link.
The device you are using should be work with the fling. It is not recognized, because the 'vmkusb_nic_fling' module is not loaded as expected.
Please help to check if your install is corrected? As you ar

localcli system module list | grep usb

You should be able to see the module is listed.

vmkusb_nic_fling true true

Please help to double check it is installed and rebooted the host as detailed in the instructions tap.
Thanks,
Songtao

Mar 27, 2019

Thank you Songtao,

This is in the install environment, on booting to install media it says "no network devices detected" so I entered shell while within the install to check. Do I need to manually enter the device into esx.conf in order for the OS install to continue?

Mar 27, 2019
Mar 27, 2019

Songtao,

The method that I used to inject the driver is with the ESXi Customizer script from here: https://www.v-front.de/p/esxi-customizer-ps.html

I did check the module and it is loaded/enabled (true/true).

I can certainly try the above mentioned link, just need to find a linux box to do so. Thanks!

Mar 27, 2019

The work around was to actually remove the vib from the ISO, and use /bin/mcopy -i from another USB key to copy the vib to /tmp, then localcli software vib install in the live install environment. Appears to be working, much appreciated!

Apr 12, 2019

Rennyfuchs, Please can you explain how you made your TP-Link UE300 to work. I don't understand fully your comment above.
Thanks In advance!

Apr 19, 2019

CikaKure, what I wound up doing was using PowerCLI to create a new image profile, then used v-front.de's customizer script to make it an ISO (https://www.v-front.de/p/esxi-customizer-ps.html)
Download and install PowerCLI
Download the offline bundle of your choosing
From PowerCLI:
Add-EsxSoftwareDepot C:\path\to\zipfile
Get-EsxImageProfile to list the profiles it has
New-EsxImageProfile -CloneProfile (name of profile from previous step) -Name MyNewImage -vendor "Me" -AcceptanceLevel CommunitySupported
Export-EsxImageProfile -ImageProfile MyNewImage -ExportToBundle myimage.zip

Then use the customizer script to make it an ISO, and add the driver:
.\ESXi-Customizer-PS-v2.6.0.ps1 -izip .\myimage.zip -pkgDir (location of fling driver)

Apr 19, 2019

In hindsight, this can also be done just by using the customizer script, for some reason when I ran it before it didn't modify the image profile from the script, but have verified that this should work:
.\ESXi-Customizer-PS-v2.6.0.ps1 -izip -v6X (specify v65 or v67) -pkgDir (location of fling driver)

Dec 24, 2019

@rennyfuchs, I am trying to do the same thing as you (install ESXI with only a USB NIC). I can get the esxi installer running but it fails at 85% with the following:
Exception: No vmknic tagged for management was found

Did you ever run into this?

Mar 26, 2019

Songtao/William,

Please add the TP-Link UE300 to the devices list? Chipset: RTL8153, Product: 0x0601, Vendor: 0x2357.

Thanks in advance!

Mar 27, 2019

Thanks aviegas for the feedback, sure, we will add it in the supported list :)

Jun 03, 2019

Hi Songtao/William, is there an ETA for the next version of this fling? I have the same adapter and they are relatively easy to get here.
Thanks,
Tony

Mar 23, 2019

Mine is not install :(

[root@EX-Server:~] ls
ESXi670-VMKUSB-NIC-FLING-20124247-offline_bundle-11613968.zip local.tgz tardisks.noauto
altbootbank locker tmp
bin mbr usr
bootbank opt var
bootpart.gz proc vghetto-ax88179-esxi65.vib
bootpart4kn.gz productLocker vmfs
dev sbin vmimages
etc scratch vmupgrade
lib store
lib64 tardisks
[root@EX-Server:~] esxcli software vib install -d /ESXi670-VMKUSB-NIC-FLING-20124247-offline_bundle-11613968.zip
Installation Result
Message: Host is not changed.
Reboot Required: false
VIBs Installed:
VIBs Removed:
VIBs Skipped: VMW_bootbank_vmkusb-nic-fling_0.8-1vmw.670.2.48.20124247
[root@EX-Server:~]

Mar 23, 2019

Would you please check if the host in Maintenance Mode or not? As 'Instructions'

Step 2 - Place the ESXi host into Maintenance Mode using the vSphere UI or CLI (e.g. esxcli system maintenanceMode set -e true)

Mar 23, 2019

Yup. That's the first thing I did and it returns it is enabled..

Mar 23, 2019

Would you please share the vmkernel.log for analysis and build number(vmware -vl), so I can check more on my side? Thanks!

Mar 23, 2019

Thanks arod!

From the log, it seems the vmkusb_nic_fling has already installed successfully, and loaded.
I only see xhci is working as expected, but no device claimed.
Is there any USB NIC device plugged on the host?
Thanks,
Songtao

2019-03-24T01:53:58.382Z cpu2:2097593)vmkusb_nic_fling loaded successfully.
2019-03-24T01:53:58.384Z cpu4:2097592)VMK_PCI: 914: device 0000:00:14.0 pciBar 0 bus_addr 0xa1220000 size 0x10000
2019-03-24T01:53:58.384Z cpu4:2097592)WARNING: xhci_pci_attach:208: xhci devid 0xa36d8086: Success
2019-03-24T01:53:58.406Z cpu4:2097592)DMA: 679: DMA Engine 'xhci0 dma' created using mapper 'DMANull'.

Mar 23, 2019

Looks like it sees my USB =/

(RTL8152)

[root@EX-Server:~] lsusb
Bus 001 Device 004: ID 062a:4101 Creative Labs Wireless Keyboard/Mouse
Bus 001 Device 003: ID 046d:c52f Logitech, Inc. Unifying Receiver
Bus 001 Device 002: ID 0bda:8152 Realtek Semiconductor Corp. RTL8152 Fast Ethernet Adapter
Bus 001 Device 001: ID 0e0f:8003 VMware, Inc.

Mar 23, 2019

Yeh, it is. Currently the module supports RTL8153 (Gagibit), but not RTL8152 (100M). We will add it in the supported list in next update. Sorry for the inconvenience.
Thanks,
Songtao

Mar 23, 2019

[root@EX-Server:~] vmware -vl
VMware ESXi 6.7.0 build-10302608
VMware ESXi 6.7.0 Update 1

Mar 22, 2019

DOesn't recognize TP link adapter (it uses RTL8153 chipset so in theory should work with usb network drivers). Installed it on ESXi 6.7.

Seems to be installed properly
localcli system module list | grep usb
vmkusb_nic_fling true true

but still doesn't recognize adapter.

Any tips how to troubleshoot and where to look?

Mar 22, 2019

Only relevant thing I've found so far

2019-03-23T05:17:41.568Z cpu0:2097534)Loading module vmkusb_nic_fling ...
2019-03-23T05:17:41.569Z cpu0:2097534)Elf: 2101: module vmkusb_nic_fling has license VMware
2019-03-23T05:17:41.579Z cpu0:2097534)Device: 192: Registered driver 'vmkusb_nic_fling' from 17
2019-03-23T05:17:41.579Z cpu0:2097534)Mod: 4962: Initialization of vmkusb_nic_fling succeeded with module ID 17.
2019-03-23T05:17:41.579Z cpu0:2097534)vmkusb_nic_fling loaded successfully.
2019-03-23T05:17:41.583Z cpu1:2097533)VMK_PCI: 914: device 0000:00:14.0 pciBar 0 bus_addr 0xdf130000 size 0x10000
2019-03-23T05:17:41.583Z cpu1:2097533)WARNING: xhci_pci_attach:208: xhci devid 0x9d2f8086: Success
2019-03-23T05:17:41.583Z cpu1:2097533)DMA: 679: DMA Engine 'xhci0 dma' created using mapper 'DMANull'.
2019-03-23T05:17:41.583Z cpu1:2097533)VMK_PCI: 764: device 0000:00:14.0 allocated 1 MSI interrupt
2019-03-23T05:17:41.647Z cpu0:2097533)Device: 327: Found driver vmkusb_nic_fling for device 0x56a243047ece922c

but i don't see any errors. (((

Mar 23, 2019

Vlad,
Thanks for the feedback.
In this case, the driver module working as expected, but unfortunately, we have not add the device in the support list yet (See the tested devices listed in the 'Requirement' tap for the detail VID/PID. In a short term, please using the tested devices in the list or working devices as other folks's feedback.
We will support it along with more other types devices in the following update version.
Thanks,
Songtao