Comment thread started by Anonymous on PowerCLI Extensions

Full comments
Jul 17, 2016

Trying this with PowerCLI 6.3 R1 with the version for 6.3R1 and higher in the downloads. However, I get this error when attempting to load the module.

PowerCLI C:\> import-module VMware.VimAutomation.Extensions
import-module : Could not load file or assembly 'file:///C:\Program Files (x86)\VMware\Infrastructure\vSphere
PowerCLI\Modules\VMware.VimAutomation.Extensions\VMware.VimAutomation.Extensions.dll' or one of its dependencies.
Operation is not supported. (Exception from HRESULT: 0x80131515)
At line:1 char:1
+ import-module VMware.VimAutomation.Extensions
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [Import-Module], FileLoadException
+ FullyQualifiedErrorId : System.IO.FileLoadException,Microsoft.PowerShell.Commands.ImportModuleCommand

Running on Windows 10

PowerCLI C:\> $PSVersionTable

Name Value
---- -----
PSVersion 5.0.10586.494
PSCompatibleVersions {1.0, 2.0, 3.0, 4.0...}
BuildVersion 10.0.10586.494
CLRVersion 4.0.30319.42000
WSManStackVersion 3.0
PSRemotingProtocolVersion 2.3
SerializationVersion 1.1.0.1

Jul 18, 2016

Probably because files downloaded from the web are blocked. Can you try go through all the files of the Extensions module and do:

Right Click - > Properties -> Tick "Unblock" check box -> OK

Then try to import the module in a new PS sessions?

-Dimitar Milov

Jul 18, 2016

Thanks Dimitar :)
There was no unblock after I'd unzipped and that's probably why I didn't catch this earlier. I went back to the .Zip and found the unblock, after that, I extracted it and placed it in my module path and everything worked great!