Comment thread started by Anonymous on PowerCLI Extensions

Full comments
Sep 20, 2017

Hello,

I'm using the PowerCLI 6.5 R1 Extenstions in a vSphere 6.5 environment and I'm receiving an error with some hosts in my environment when using the Get-VMHostVFlashConfiguration cmdlet.

$ESXi = "esxi.hostname.fqdn"
$localDisk = Get-ScsiLun -VMHost $ESXi | Where {$_.CapacityGB -eq 372}
### checks occur to ensure $localDisk is marked for Flash
$vFlashConfig = Get-VMHostVFlashConfiguration -VMHost $ESXi
$vFlashDisk = $localDisk | Get-VMHostDisk
If ($vFlashConfig.CapacityGB -eq 0) {Set-VMHostVFlashConfiguration -VFlashConfiguration $vFlashConfig -AddDevice $vFlashDisk}

The error occurs when setting the $vFlashConfig variable.
Get-VMHostVFlashConfiguration The object 'vim.HostSystem:host-xxx' has already been deleted or has not been completely created.

CategoryInfo: NotSpecified: (:) [Get-VMHostVFlashConfiguration], Managed ObjectNotFound
FullQualifiedErrorID: VICore_StorageServiceImpl_GetVMHostVFlashConfigurationViewListSingleHost_ViError,VMware.VimAutomation.ViCore.Cmdlets.Commands.Host.Storage.GetVMHostVFlashConfiguration

This error occurred on several of the ESXi hosts in our environment. We successfully used the extension cmdlets to configure vFlash on most of the hosts which are the same model (Dell M630 blades). I manually configured vFlash successfully on a few of the hosts that had this error (that is to say, every hosts I attempted was configured successfully but I did not attempt to configure them all) but still received the same error message when running the above command after vFlash is configured. Not sure if this is a problem with the cmdlet or there is an issue with my hosts that have this error.