Jun 23, 2017

I was able to resolve the double login issue by doing the following:

apt-get purge lightdm
apt-get install lightdm
then running horizon-optimizer.sh again answering all 2's to the questions.

Ryan- Please integrate this fix into your next OVA. You probably only need to purge lightdm before you rebuild. When you generate the OVA please use CLI option:
--shaAlgorithm=sha1

so us C# people can still use it. Thanks for all your hard work on this, I never would have been able to tackle an AD-integrated Horizon Ubuntu workstation myself!

Oct 25, 2017

Jon - finally have time to be revisiting this. The interesting thing is lightdm doesn't get installed until horizon-optimizer.sh is ran. I'm not sure at what point after it gets installed, something goes awry requiring the package purge. We can try putting the install later in the script, but it's possible a configuration or installation outside of my script is affecting it.

Nov 07, 2017

This issue is due to the adding of this line by the script in /etc/pam.d/lightdm
auth requisite pam_vmw_cred.so
But I don't know whiches parameters we can replace to resolve this

Jun 23, 2017

Thanks Jon for the input! I will certainly address this in the next build.

Jun 19, 2017

I am having to login twice as well. Any update on this?

Jun 06, 2017

After running the agent installer script it now takes 2 attempts to login. Before running the script login worked fine. I have verified the viewadmin password is correct. A yellow password line appears during the second login attempt and using the same credentials will then log in on the second attempt Same issue even if using other accounts to login. Any ideas?

Jun 23, 2017

See my comment above, the fix is:

apt-get purge lightdm
apt-get install lightdm
then running horizon-optimizer.sh again answering all 2's to the questions.

Jun 06, 2017

In case it helps, here's a copy of the authd log:
Jun 6 11:44:56 ubuntu16x64-tmp-vc3 polkitd(authority=local): Unregistered Authentication Agent for unix-session:c4 (system bus name :1.81, object path /org/mate/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8) (disconnected from bus)
Jun 6 11:44:56 ubuntu16x64-tmp-vc3 lightdm: pam_unix(lightdm:session): session closed for user viewadmin
Jun 6 11:44:57 ubuntu16x64-tmp-vc3 lightdm: PAM unable to dlopen(pam_kwallet.so): /lib/security/pam_kwallet.so: cannot open shared object file: No such file or directory
Jun 6 11:44:57 ubuntu16x64-tmp-vc3 lightdm: PAM adding faulty module: pam_kwallet.so
Jun 6 11:44:57 ubuntu16x64-tmp-vc3 lightdm: PAM unable to dlopen(pam_kwallet5.so): /lib/security/pam_kwallet5.so: cannot open shared object file: No such file or directory
Jun 6 11:44:57 ubuntu16x64-tmp-vc3 lightdm: PAM adding faulty module: pam_kwallet5.so
Jun 6 11:44:57 ubuntu16x64-tmp-vc3 lightdm: pam_unix(lightdm-greeter:session): session opened for user lightdm by (uid=0)
Jun 6 11:44:57 ubuntu16x64-tmp-vc3 systemd: pam_unix(systemd-user:session): session opened for user lightdm by (uid=0)
Jun 6 11:44:57 ubuntu16x64-tmp-vc3 systemd-logind[868]: New session c5 of user lightdm.
Jun 6 11:44:58 ubuntu16x64-tmp-vc3 lightdm: PAM unable to dlopen(pam_kwallet.so): /lib/security/pam_kwallet.so: cannot open shared object file: No such file or directory
Jun 6 11:44:58 ubuntu16x64-tmp-vc3 lightdm: PAM adding faulty module: pam_kwallet.so
Jun 6 11:45:01 ubuntu16x64-tmp-vc3 lightdm: PAM unable to dlopen(pam_kwallet.so): /lib/security/pam_kwallet.so: cannot open shared object file: No such file or directory
Jun 6 11:45:01 ubuntu16x64-tmp-vc3 lightdm: PAM adding faulty module: pam_kwallet.so
Jun 6 11:45:07 ubuntu16x64-tmp-vc3 lightdm: pam_succeed_if(lightdm:auth): requirement "user ingroup nopasswdlogin" not met by user "viewadmin"
Jun 6 11:45:11 ubuntu16x64-tmp-vc3 lightdm: pam_unix(lightdm-greeter:session): session closed for user lightdm
Jun 6 11:45:11 ubuntu16x64-tmp-vc3 lightdm: pam_unix(lightdm:session): session opened for user viewadmin by (uid=0)
Jun 6 11:45:11 ubuntu16x64-tmp-vc3 systemd-logind[868]: New session c6 of user viewadmin.
Jun 6 11:45:11 ubuntu16x64-tmp-vc3 gnome-keyring-daemon[35165]: The PKCS#11 component was already initialized
Jun 6 11:45:11 ubuntu16x64-tmp-vc3 gnome-keyring-daemon[35165]: The Secret Service was already initialized
Jun 6 11:45:11 ubuntu16x64-tmp-vc3 polkitd(authority=local): Registered Authentication Agent for unix-session:c6 (system bus name :1.123 [/usr/lib/x86_64-linux-gnu/polkit-mate/polkit-mate-authentication-agent-1], object path /org/mate/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)
Jun 6 11:45:11 ubuntu16x64-tmp-vc3 gnome-keyring-daemon[35165]: The SSH agent was already initialized
Jun 6 11:45:14 ubuntu16x64-tmp-vc3 pkexec: pam_unix(polkit-1:session): session opened for user root by (uid=1000)
Jun 6 11:45:14 ubuntu16x64-tmp-vc3 pkexec: pam_systemd(polkit-1:session): Cannot create session: Already running in a session
Jun 6 11:45:14 ubuntu16x64-tmp-vc3 pkexec[35647]: viewadmin: Executing command [USER=root] [TTY=unknown] [CWD=/home/viewadmin] [COMMAND=/usr/lib/update-notifier/package-system-locked]
Jun 6 11:45:22 ubuntu16x64-tmp-vc3 dbus[763]: [system] Failed to activate service 'org.bluez': timed out
Jun 6 11:45:47 ubuntu16x64-tmp-vc3 dbus[763]: [system] Failed to activate service 'org.bluez': timed out
Jun 6 11:46:57 ubuntu16x64-tmp-vc3 systemd-logind[868]: Removed session c5.
Jun 6 11:46:57 ubuntu16x64-tmp-vc3 systemd: pam_unix(systemd-user:session): session closed for user lightdm

May 22, 2017

Hi, with the latest ova I got an error "The following manifest file entry is invalid :SHA256(Ubuntu ....ovf) ID" Is the ova is corrupted ? I already tried to download it again

Jun 19, 2017

Thanks for pointing this out Benoît, deploying from the web client worked fine for me. Is there any plan to release an OVA with the SHA1 algorithm for use c# client users?

Jun 01, 2017

Thanks for posting. Can you confirm you're able to deploy using the Web Client/HTML5 client per the blog?

May 22, 2017

Hi and thanks for the note. I just tested downloading v1.1.0 and imported the OVA without issue. Have you tested another browser or another network for the download?

May 22, 2017

trying with another browser and other OS, I got same issue. I gonna check on other network tonight. Vcenter version can be the root cause (6.0U3 in my side) ?