Please provide your feedback in this short Flings' survey.
Dec 07, 2016

Hi!
I have trouble viewing the graphs when i save the Benchmark offline. I have unzipped the folder but i get blank graphs. Graphs works fine if i view then through the machineip:/results.
Any idea what could be causing this?

Dec 07, 2016
Nov 23, 2016

Hi, I deployed the HCIBench in the VM Network same on public and private network.
Then start the test with enable the DHCP service.
I can see the HCIBench VM start the eth1 and DHCP service, But the vdbench client VM did not got the dhcp assigned ip. The client vm eth0 is up but not ip assign. Could you help on it?

=== HCIBench VM==================================
root@photon-HCIBench [ ~ ]# ifconfig
eth0 Link encap:Ethernet HWaddr 00:50:56:bb:36:0a
inet addr:10.244.140.71 Bcast:10.244.140.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:139702 errors:0 dropped:202 overruns:0 frame:0
TX packets:77350 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:10717407 (10.7 MB) TX bytes:853017747 (853.0 MB)

eth1 Link encap:Ethernet HWaddr 00:50:56:bb:31:01
inet addr:192.168.0.1 Bcast:192.168.63.255 Mask:255.255.192.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:716 errors:0 dropped:2 overruns:0 frame:0
TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:43326 (43.3 KB) TX bytes:441 (441.0 B)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:22065 errors:0 dropped:0 overruns:0 frame:0
TX packets:22065 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1
RX bytes:847535475 (847.5 MB) TX bytes:847535475 (847.5 MB)

root@photon-HCIBench [ ~ ]# service dhcp status
● dhcp.service - ISC DHCP Server
Loaded: loaded (/usr/lib/systemd/system/dhcp.service; disabled; vendor preset: enabled)
Active: active (running) since Wed 2016-11-23 02:53:54 PST; 7min ago
Docs: man:dhcpd(8)
man:dhcpd.conf(5)
Main PID: 546 (dhcpd)
CGroup: /system.slice/dhcp.service
└─546 /usr/sbin/dhcpd -f --no-pid

Nov 23 02:53:54 photon-HCIBench dhcpd[546]: Sending on Socket/fallback/fallback-net
Nov 23 02:53:54 photon-HCIBench dhcpd[546]: Server starting service.
Nov 23 02:53:54 photon-HCIBench dhcpd[546]: Listening on LPF/eth1/00:50:56:bb:31:01/192.168.0.0/18
Nov 23 02:53:54 photon-HCIBench dhcpd[546]: Sending on LPF/eth1/00:50:56:bb:31:01/192.168.0.0/18
Nov 23 02:53:54 photon-HCIBench dhcpd[546]: No subnet declaration for eth0 (10.244.140.71).
Nov 23 02:53:54 photon-HCIBench dhcpd[546]: ** Ignoring requests on eth0. If this is not what
Nov 23 02:53:54 photon-HCIBench dhcpd[546]: you want, please write a subnet declaration
Nov 23 02:53:54 photon-HCIBench dhcpd[546]: in your dhcpd.conf file for the network segment
Nov 23 02:53:54 photon-HCIBench dhcpd[546]: to which interface eth0 is attached. **
Nov 23 02:53:54 photon-HCIBench dhcpd[546]: Sending on Socket/fallback/fallback-net

Nov 23, 2016

fix that. vdbench client vm did not got the DHCP ip assign, reboot the network and then reassign it. Not sure why the vm deploy did not got the dhcp ip at once?

Nov 23, 2016

you specified static ip for the eth0 of HCIBench and both eth0 and eth1 were mapped to the same "VM Network"? Did all the client VMs deployed not get IP or just part of them?

Nov 23, 2016

yes, I set the static IP for eth0 of HCIBench for management, then eth0 and eth1 are in VM Network.
I just test to deploy 2 client VM then all of them can not got IP.

Nov 23, 2016

1. did you deploy the vms from ui?
2. u said after rebooting the dhcp service or client vm to gain the ips?

Nov 23, 2016

yes, WebUI create the client VM. I reboot the client VM to gain ips.

Nov 23, 2016

that's strange, cuz my lab is using the similar network setting and never ran into this issue.
1. everytime, none of the vms can get IPs before rebooting them?
2. after rebooting the vms, all of them can get ip?

Nov 23, 2016

A odd question why the HCIBench VM always be poweroff while I start the test from WebUI?

Nov 23, 2016

I guess you put the HCIBench VM into the folder vdb-ClusterNAME-vms? please move the HCIBench VM out of this folder.

Nov 23, 2016

yes, The HCIBench VM deploy to vbd-cluster-vms folder. In this folder, test will poweroff the HCIBench VM? what's usage for the folder?

Nov 23, 2016

this folder is for containing the client vms, not the HCIBench itself.

Nov 21, 2016

Does that HCIBench support all parameter of VDBench if I create self-defined VDBench file?

Nov 21, 2016

yes, please be aware the data disk starts from /dev/sda, so if you define 3 data disks, should be sda, sdb and sdc