Comment thread started by Othman on HCIBench

Full comments
Nov 24, 2020

Hello, I have an issue during the validation

2020-11-24 20:29:37 +0000: Validating cluster inter-connectivity...
no matches for "hosts/*/vms/hci-tvm-*"
2020-11-24 20:31:38 +0000: SSH to client VM failed
2020-11-24 20:31:38 +0000: SSH to client VM failed
2020-11-24 20:31:40 +0000: SSH to client VM failed
2020-11-24 20:31:41 +0000:
2020-11-24 20:31:42 +0000: no matches for "hosts/*/vms/hci-tvm-*"
2020-11-24 20:31:45 +0000: ------------------------------------------------------------------------------
2020-11-24 20:31:45 +0000: Unable to SSH to hcitvm, please check if your network allow SSH to go through

from the deploy-hcitvm-xxxxxxxxxx.log
PING 172.17.0.3 (172.17.0.3) 56(84) bytes of data.
64 bytes from 172.17.0.3: icmp_seq=1 ttl=64 time=0.031 ms
64 bytes from 172.17.0.3: icmp_seq=2 ttl=64 time=0.031 ms
64 bytes from 172.17.0.3: icmp_seq=3 ttl=64 time=0.023 ms
64 bytes from 172.17.0.3: icmp_seq=4 ttl=64 time=0.030 ms
64 bytes from 172.17.0.3: icmp_seq=5 ttl=64 time=0.038 ms

--- 172.17.0.3 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 55ms
rtt min/avg/max/mdev = 0.023/0.030/0.038/0.007 ms
ssh: connect to host 172.17.0.3 port 22: Connection refused

Any idea please why SSH is refused, ?
steps already taken,
ssh to esxi -->OK
rvc to esxis-->OK
thank you for your help

Nov 24, 2020

could you check if all the hci-tvm logs got the same err msg?
also, it seems like 172.17.0.3 is assigned by the DHCP service in the vlan? because docker using the same subnet 172.17.0.0/255.255.0.0, so you can either configure a different subnet for guest vms or change the docker default subnet config, to do so:
here are the steps to reconfig docker subnet:

1. SSH into HCIBench, and create file by: vi /etc/docker/daemon.json
2. add lines to the file and save it ( here we change the docker host ip to 192.168.5.1(please make sure not using 192.168 for guest vms ip prefix in my case)
{
"default-address-pools":
[
{"base":"192.168.5.0/24","size":24}
]
}
3. systemctl restart docker
4. change data source in grafana:
go to http://HCIBench_IP:3000/datasources admin/vmware, edit both graphite and influxdb by changing the ip from 172.17.0.1 to 192.168.5.1, save and test the datasource, then you should be good.