Please provide your feedback in this short Flings' survey.
Sep 20, 2021

Thanks for your precious work!
BTW, is there any hope to get back Thunderbolt ports usage?

Jul 12, 2021

Thanks for the great update!
It worked fine with the ESXi 7.0u2 and Transcend NVMe SSD.

Driver :

Tested SSD :
Transcend PCIe SSD 220S TS2TMTE220S
* controller: Silicon Motion, VID:0x126f, PID:2262

May 13, 2021

Just opened a bug. It's understood that Thunderbolt does not work when using this driver, however, the rear USB-C ports do not function in USB mode either.

Jul 06, 2021

All the rear "USB-C" ports are actually Thunderbolt-3 though

Jul 06, 2021

Yeah, I guess I was under the impression that the Thunderbolt protocol is what's broken, and when defaulting bcak to the USB protocol we'd still get functionality. I may have a misunderstanding of how the ports work though

Mar 12, 2021

Hi, I have a trouble using local ssd in Macmini8,1. After installing this fling, I'm able to see the disk, but when I try to format and use it for datastore, it crashes without any PSOD. And starts to boot again.

So I tried format it in macOS Recovery -> GPT, single partition and then format with vmkfstools. This didn't work either.

Anything I try to do with the disk in esxi (cli or web) results in crash.

Am I missing some obvious settings or something?

I'm running fresh install of ESXI Update 3 ( Build 17499825)

Mar 12, 2021

I have also tried this with ESXi 6.7.0 Update 3 (Build 16713306). Same behaviour. Any formatting, partitioning of the disk fails with sudden crash and reboot.

Jul 06, 2021

I have the same issue on the MacMini 8,1.
I installed ESXi 6.7 with Apple-T2-NVME and Aquanta 10G drivers. Trying to format the NVME SSD makes ESXi crash.

Jul 06, 2021

I tried with ESXi 6.7 U3 (14320388) and it works :-)

Jul 28, 2021

I just finished testing all the builds in between 14320388 ==> 16713306 (which does NOT work at all on my Mac Mini 2018).

I found that these builds all work to some degree:


For kicks I also tried the latest 6.7 release (17700523) which did NOT work (as expected)

YMMV ... hope to see updates soon with support for 7.x releases!

Jul 27, 2021

@Fravadona Thanks for this. I'm running into that exact same crash - Mac Mini 2018 w/ 1TB internal NVMe. Will try build 14320388 as you suggest. How did you figure this out? Trial and error?