Please provide your feedback in this short Flings' survey.
Jan 25, 2021

We've been using this fling to amazing success in our 6.5 & 6.7 vCenters. I'm working on rolling out our 7.0 environment and the fling is failing at the template-export stage with the error

Failed to generate deployment template
[ERROR] (vmodl.fault.InvalidArgument)
{dynamicType = <unset>,
dynamicProperty = (vmodl.DynamicProperty) [],
msg = 'A specified parameter was not correct: spec.userName',
faultCause = <unset>,
faultMessage = (vmodl.LocalizableMessage) [],
invalidProperty = u'spec.userName'

I'd appreciate any thoughts on what might be creating this error.

Nov 22, 2016

Hi Massimiliano, will it work in a vCSA 6.0U2 scenario, or do I need a vCenter Server installation? And if vCSA, where should I install the plugin? Thank you and many thanks for your work!

Sep 21, 2016

"Create Answer Template" does not work with Host profile of ESXi 6. The logs of Auto Deploy Gui show:

[2016-09-21 16:59:04] ClientUIThread ERROR autodeploy.Globals - autodeploy60
[2016-09-21 16:59:04] ClientUIThread ERROR autodeploy.Globals - Object reference not set to an instance of an object.
[2016-09-21 16:59:04] ClientUIThread ERROR autodeploy.Globals - at autodeploy.Wizard.AddProfileTemplate.FormAddProfileTemplate.AddPages()

Jan 25, 2016

I've seen comments that the 5.1 issue with it not working has been fixed, however I'm still having issues (as are others when I read the comments). After installing the latest version of Auto Deploy GUI (4311) the Auto Deploy GUI plugin doesn't even show up in the Plug-in list. I don't think I'm the only one with the issue. Is this a known problem? Any suggestions on how to resolve?